Chon · 翀

The Neverland Blog

RouterOS

DDNS

New Script: script-ddns

:local result [/tool fetch url="https://dyn.dns.he.net/nic/update?hostname=&password=" output=user as-value];
:log info $result;

New Schedule: schedule-script-ddns

:execute "script-ddns"

New Script: script-email-ip

:local ipaddr [/ip address get [/ip address find interface="pppoe-out1"] address];
/tool e-mail send to="user@domain.local" subject="New IP Address" body=$ipaddr;

PPP Profile – On Up

delay 30s
:execute "script-ddns"
:execute "script-email-ip"